Kioskea
Recherche
Faça uma pergunta »

Excel: Tutorial Função PROCH (HLOOKUP)

Março 2015


Procedimento do PROCH (Excel 2003 e Excel 2007)



Referências

  • Você deve selecionar as referências em sua planilha. Neste exemplo, a sua referência é $A$1:$F$4. Depois de selecioná-la, clicar em Inserir - Nome - Definir (Para este exemplo, dei o nome de PRODUTOS).


Excel 2007: A definição do nome é feita através do menu Fórmulas.

Local onde os dados encontrados aparecerão

  • Neste exemplo:
    • J1=Termo a ser procurado
    • J3=Descrição encontrada (coluna 2 da nossa planilha)
    • J5=Quantidade encontrada (coluna 3 da nossa planilha)
    • J7=Preço encontrado (coluna 4 da nossa planilha)

Fórmulas


A sintaxe de base da função PROCH é:
= PROCH (valor_pesquisa;tabela_matriz;no_index_lig;valor_aproximado)
(=HLOOKUP(lookup_value,table_array,row_index_num,range_lookup)

(tutorial PROCH)
  • J3
    • =PROCH ($J$1;PRODUTOS;2;FALSO)
    • Para ser mais claro, partindo do conteúdo da célula H1, procuramos na primeira linha da tabela PRODUTOS, a coluna começando com esse conteúdo, e extraímos o valor colocado na segunda linha; FALSO, indica que estamos procurando uma correspondência exata.
    • Para evitar a mensagem #N/A, se nada foi encontrado, utilizamos a fórmula seguinte e "Desconhecido" aparecerá na célula do resultado.
    • =SE(FORNA(PROCH($J$1;PRODUTOS;2;FALSO));"Desconhecido";PROCH($J$1;PRODUTOS;2;FALSO))

(Veja a função SE ou IF aqui)


*
    • Com o Excel 2007 existe uma fórmula mais curta: =SEERRO(PROCH($J$1;PRODUTOS;2;FALSO);"Desconhecido")
  • J5
    • =PROCH ($J$1;PRODUTOS;3;FALSO)
    • Simplificando, partindo do conteúdo da célula H1, procuramos na primeira linha da tabela PRODUTOS, a coluna começando com esse conteúdo, e extraímos o valor colocado na terceira linha; FALSO, indica que estamos procurando uma correspondência exata.
    • Para evitar a mensagem #N/A, se nada foi encontrado, utilizamos a fórmula seguinte e "Desconhecido" aparecerá na célula do resultado.
    • =SE(FORNA(PROCH($J$1;PRODUTOS;3;FALSO));" Desconhecido "; PROCH ($J$1;PRODUTOS;3; FALSO))
    • Com o Excel 2007 existe uma fórmula mais curta: =SEERRO(PROCH($J$1;PRODUTOS;3;FALSO);"Desconhecido")
  • J7
    • =PROCH($J$1;PRODUTOS;4;FALSO)
    • Simplificando, partindo do conteúdo da célula H1, procuramos na primeira linha da tabela PRODUTOS, a coluna começando com esse conteúdo, e extraímos o valor colocado na quarta linha; FALSO, indica que estamos procurando uma correspondência exata.
    • Para evitar a mensagem #N/A, se nada foi encontrado, utilizamos a fórmula seguinte e "Desconhecido" aparecerá na célula do resultado.
    • =SE(FORNA(PROCH($J$1;PRODUTOS;4;FALSO);"Desconhecido";PROCH($J$1;PRODUTOS;4;FALSO))
    • Com o Excel 2007 existe uma fórmula mais curta: =SEIERRO(PROCH($J$1;PRODUTOS;4;FALSO);"Desconhecido")

Nota: Na fórmula, definimos como FALSO se você quiser procurar o valor exato (# N/A se não for encontrado) e, VERDADEIRO se o valor for igual ou inferior mais próximo; neste caso, a lista de valores deve estar organizada.
Se este parâmetro for omitido, seu valor padrão é VERDADEIRO.


Tradução feita por Lucia Maurity y Nouira
Para uma leitura offline, é possível baixar gratuitamente este artigo no formato PDF:
Excel-tutorial-funcao-proch-hlookup.pdf

A ver igualmente

Na mesma categoria

Fonction RECHERCHEH sur Excel
Por Ricky38 em 9 de dezembro de 2009
Artigo original publicado por Ricky38. Tradução feita por pintuda. - última modificação por ninha25
Este documento, intitulado « Excel: Tutorial Função PROCH (HLOOKUP) »a partir de Kioskea (pt.kioskea.net) está disponibilizado sob a licença Creative Commons. Você pode copiar, modificar cópias desta página, nas condições estipuladas pela licença, como esta nota aparece claramente.