Faça uma pergunta »

Tutorial Função PROCV (VLOOKUP)

Maio 2015



Procedimento do PROCV(Excel 2003 & Excel 2007)



Referências

  • Você deve selecionar as referências em sua planilha. Neste exemplo, a sua referência é $A$2:$D$10. Depois de selecioná-la, clicar em Inserir - Nome - Definir (Para este exemplo, dei o nome de CAMPOS).


Excel 2007: A definição do nome é feita através do menu Fórmulas.

Local onde os dados encontrados aparecerão

  • Neste exemplo:
    • H1= Termo a ser procurado
    • H4= Descrição encontrada (coluna 2 da nossa planilha)
    • H6= Quantidade encontrada (coluna 3 da nossa planilha)
    • H8= Preço encontrado (coluna 4 da nossa planilha)

Fórmulas


A sintaxe de base da função PROCV é:
=PROCV(valor_pesquisa;tabela_matriz;no_index_lig;valor_aproximado)
(=VLOOKUP(lookup_value,table_array,row_index_num,range_lookup)
  • H4
    • =PROCV($H$1;CAMPOS;2;FALSO)
    • Para ser mais claro, partindo do conteúdo da célula H1, procuramos na primeira linha da tabela CAMPOS, a coluna começando com esse conteúdo, e extraímos o valor colocado na segunda linha; FALSO, indica que estamos procurando uma correspondência exata.
    • Para evitar a mensagem #N/A, se nada foi encontrado, utilizamos a fórmula seguinte e "Desconhecido" aparecerá na célula do resultado.
    • =SE(FORNA(PROCV($H$1;CAMPOS;2;FALSO));"Desconhecido";PROCV($H$1;CAMPOS;2;FALSO))
    • Com o Excel 2007 existe uma fórmula mais curta: =SEERRO(PROCV($H$1;CAMPOS;2;FALSO);"Desconhecido")
  • H6
    • =PROCV($H$1;CAMPOS;3;FALSO)
    • Simplificando, partindo do conteúdo da célula H1, procuramos na primeira linha da tabela CAMPOS, a coluna começando com esse conteúdo, e extraímos o valor colocado na terceira linha; FALSO, indica que estamos procurando uma correspondência exata.
    • Para evitar a mensagem #N/A, se nada foi encontrado, utilizamos a fórmula seguinte e "Desconhecido" aparecerá na célula do resultado.
    • =SE(FORNA(PROCV($H$1;CAMPOS;3;FALSO));"Desconhecido";PROCV($H$1;CAMPOS;3;FALSO))
    • Com o Excel 2007 existe uma fórmula mais curta: =SEERRO(PROCV($H$1;CAMPOS;3;FALSO);"Desconhecido")
  • H8
    • =PROCV($H$1;CAMPOS;4;FALSO)
    • Simplificando, partindo do conteúdo da célula H1, procuramos na primeira linha da tabela CAMPOS, a coluna começando com esse conteúdo, e extraímos o valor colocado na quarta linha; FALSO, indica que estamos procurando uma correspondência exata.
    • Para evitar a mensagem #N/A, se nada foi encontrado, utilizamos a fórmula seguinte e "Desconhecido" aparecerá na célula do resultado.
    • =SE(FORNA(PROCV($H$1;CAMPOS;4;FALSO));"Desconhecido";PROCV($H$1;CAMPOS;4;FALSO))
    • Com o Excel 2007 existe uma fórmula mais curta: =SEERRO(PROCV($H$1;CAMPOS;4;FALSO);"Desconhecido")


Nota: Na fórmula, definimos como FALSO se você quiser procurar o valor exato (# N/A se não for encontrado) e, VERDADEIRO se o valor for igual ou inferior mais próximo; neste caso, a lista de valores deve estar organizada.
Se este parâmetro for omitido, seu valor padrão é VERDADEIRO.


Tradução feita por Lucia Maurity y Nouira
Para uma leitura offline, é possível baixar gratuitamente este artigo no formato PDF:
Tutorial-funcao-procv-vlookup.pdf

A ver igualmente

Na mesma categoria

Excel - The VLOOKUP function
Por aakai1056 em 19 de março de 2011
Fonction RECHERCHEV sur Excel
Por Ricky38 em 9 de dezembro de 2009
Artigo original publicado por Ricky38. Tradução feita por pintuda. - última modificação por ninha25
Este documento, intitulado « Tutorial Função PROCV (VLOOKUP) »a partir de Kioskea (pt.kioskea.net) está disponibilizado sob a licença Creative Commons. Você pode copiar, modificar cópias desta página, nas condições estipuladas pela licença, como esta nota aparece claramente.